How To Install Ruby 2.1.2 On CentOS 6.5

1. Fist make sure your system is up to date

yum update -y 

2. Then you need to install the development tools needed:

yum groupinstall -y development

3.Download and install rvm with curl

curl -L get.rvm.io | bash -s stable

4.  Setup the system environment using rvm shell script:

source /etc/profile.d/rvm.sh

5.  Now it’s time to install ruby I’m installing ruby 2.1.2

rvm get head
rvm install 2.1.2 

Note:
you can get a error saying:
‘Error installing EPEL, it is required for libyaml-devel,
either there was an error installing EPEL package,
or there was problem checking if libyaml-devel is available / installed.’ Usually you can ignore this and run the rvm install 2.1.2 again.
if you are unsure if libyaml-devel is installed you can check this by typing:

yum info libyaml-devel

6. Check ruby version

ruby -v
Read more interesting ruby posts:

I am a Senior System Administrator that work daily with Virtualization,Xenserver, Linux, IT automation, Ansible,Windows, Active Directory, Exchange and a lot more. Here you will find tips and trix from early junior, middle junior and senior to unique information of the topics I mentioned earlier. If you need help with something do not hesitate to contact me I will gladly help.

Tagged with: , , , ,